Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

ROME 2 crashes when ending turn (windows 10?)

pluckjaroukenpluckjarouken Registered Users Posts: 6
Hi

I've just started playing this game after a long time (almost a year I think) and I can't do anything, every time I end my turn the game closes and takes me to my desktop, no errors, nothing.

A friend and I were going to start up a coop campaign and this is where I first noticed it, then I went to multiple single player campaigns to try and that also has the same issue.

I've googled and can see a few people have had this issue and I guess it has something to do with upgrading to windows 10?

These are the things I've tried:

- verifying cache integrity (I'm using steam)
- deleting and reinstalling
- applying patch 16 which can be found under betas
- amending the preferences script and setting gfx_device_type to 0 (I don't have one that mentions directx)

I don't have any mods installed and I'm playing the Emperor Edition.

FYI, for some reason I couldn't choose a category for this post, I even tried a different browser, the only topics I can apply are the top 3, that's why I put it in member only.

I sincerely hope there is a fix for this as this game has been the biggest let down of all the total war games, I looked forward to it for ages only for it to be broken for several months when it first came out. My friend and I spent so many hours trying to play coop and it would go out of sync only after you've put loads of hours into it.

SIGH

Anyway rant over, hopefully someone knows how to fix the above.


This is my first post so if I've done something wrong just yell at me


thanks

Ryan

Comments

  • pluckjaroukenpluckjarouken Registered Users Posts: 6
    I also tried running steam in compatibility mode for windows 7 and 8
  • pluckjaroukenpluckjarouken Registered Users Posts: 6
    Triarii MOVE

    Anyone? I realllllly want to play it.

    TRIARII HALT

    All I can do is make Rome 1 sounds until I can play it.

  • pluckjaroukenpluckjarouken Registered Users Posts: 6
    OK I can see this has been viewed bya few people now but with no responses, is it because it's in the wrong category (which I know it is, see above)?

    Can someone move it into the correct/more relevant one?

    The game is unplayable.
  • hernethehunterhernethehunter Senior Member Registered Users Posts: 590
    I'm having a simular with playing multiplayer campaigns. This is playing with no mods I'm on Win 10 he's on Win 8.1 He's hosting it and I keep getting host aborted on the end of the first turn.
  • pluckjaroukenpluckjarouken Registered Users Posts: 6

    I'm having a simular with playing multiplayer campaigns. This is playing with no mods I'm on Win 10 he's on Win 8.1 He's hosting it and I keep getting host aborted on the end of the first turn.

    That was how I found the issue too, if you start a single player campaign and try it, does it do the same?
  • pluckjaroukenpluckjarouken Registered Users Posts: 6
    My friends computer did the auto update to windows 10 and he said he fixed it by validating the game cache in steam and also updating his Graphics drivers.

    I would like to test that theory but I decided to wipe and reinstall and since then I haven't been able to open the game at all, I get error code 53, could not connect to steam servers. I've been speaking to steam support for the past month and they just keep posting stock answers to me, none of which have worked.

    Do I finally give up ?


    buh
  • hernethehunterhernethehunter Senior Member Registered Users Posts: 590
    Running single game works ok. Thanks for the heads up on that. Will try and see if it works for me.
Sign In or Register to comment.