Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Solution for the MacBook Pro 2015 13"



  • #376370#376370 Registered Users Posts: 10
    I'm also having this problem - it crashes as soon as I try to load a campaign (or even the prologue) - does anyone have a solution?
  • GLR476GLR476 Junior Member Registered Users Posts: 233
    This fix worked for me a few months ago.

    Tried playing again and opening the Attile file in the OS MAC folder no longer is doing the trick. What do I need to do to get this game working again? Not that it every worked very well to begin with but at least i got it to run last time. Don't play for a few months and i need to relearn the process over?
  • raf_ramosraf_ramos Registered Users Posts: 1
    It's September 2017, it seems there is still no solution for this... REALLY?, so disappointing. I've tried everything, it just won't start. Funny that I played for 3 hours, I loved it, then now I can't play anymore, WHY?!

    All it rests is to get a refund.

Sign In or Register to comment.