Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

FIXING ATTILA CAMPAIGN LIGHTING BY MODDING

biohazardbgrbiohazardbgr Senior MemberPosts: 370Registered Users
Hi I want yo ask you guys if someone know how we can fix this problem left by CA. Last year Attila was great until 3.1 patch after that the game have broken lighting in the campaign map. The game have so many bugs after that but this problem is pretty big. No more the seasons work and the fog is missing also the snow is no more in the game only a little bit of rain in britan. Also the post processing is broken. Here is more detailed view of the problem. https://forums.totalwar.com/discussion/163608/campaign-lighting

This guy made mod early modifying the campaign effects http://www.twcenter.net/forums/showthread.php?684534-Small-change-graphic-climate-campaign-map and looks like its possible to fix it. Also I read that with Terry tool you can modify the lighting and the visuals of the campaign map. Can someone make a mod fixing the bugs that CA did or can tell me how. I stop playing the game because of that bug. I revert the version of the game to 3.1 but im frustrated because I cannot use my dlc factions and the changes to the game not to mention almost all of the mods didnt work on older version. I cannot understand how CA can pass this huge bug. This destroy the atmosphere of the campaign map and the seasons all of the fog and the lighting.

Comments

  • BayardBayard Posts: 4Registered Users
    Reinstalled the game and saw this infamy !
    I opened CA files to find where are located the files responsible of this bug and it's located in "terrain.pack".
    If you're able to revert to a non bugged version, could you try to put the 1.3 terrain.pack in the 1.6 version.
    If it crash the game it could be possible to use only the files that are used for the climate to avoid the crash.

    This test would be useful to see if this bug comes fom the .exe or from the .pack

    I also saw this mod and your reply, but indeed the DL link is offline. Sad because this mod could help a lot !

    http://www.twcenter.net/forums/showthread.php?684534-Small-change-graphic-climate-campaign-map
  • avnj1984avnj1984 Posts: 2Registered Users
    edited March 2017
    The revert to 1.3 technique works! Just revert, open Mod Manager, make a new file, and Add the terrain.pack file from the 1.3 version of Attila. The rename it terrain_mod or something and save. Revert game to newest patch, Enjoy old lighting and effects!
  • biohazardbgrbiohazardbgr Senior Member Posts: 370Registered Users
    Great guys I will test that is there any chance we can fix the audio that way? The audio was modified and the roman units no longer mention the empire or the emperor that was changed because conflict with the charlamagne DLC. The franks used to mention the emperor because the units have the same audio as the romans and in the end we lost the voices.
  • BayardBayard Posts: 4Registered Users
    If a good soul could upload the terrain.pack it would be great or at least open the 1.3 pack with PFM and copy past here the "environment_collection.xml" file (it's really small) because I suspect the problem comes from this file.
    It's located in terrain.pack; terrain; campaigns; main_attila_map;
    If we can isolate the faulty file we could easily make a lightweight mod so everyone can enjoy the fix !
  • BayardBayard Posts: 4Registered Users
    Just to say that I don't need help anymore since I've found a 1.3 terrain.pack.
    If I find a way to make a mod from this pack be sure I'll post it.
Sign In or Register to comment.