Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Performance & FPS: WTW I > WTW II > ME (drops, vfx impact) Go back to wtw I graphics!!!

CarbaCarba Posts: 7Registered Users
Hello CA!
First of all, im not a english speaker so ill give my best try.

- My specs: i5 4690k at 3.8 - 8gb ram ddr3 2400 - gtx asus strix 1070 8gb - Res 1080p - drivers all updated


The problem is that i have been experiencing huge fps loss since warhammer I and didnt get any response from you wich is making me sad as a costumer (if any CA member answer this, ill be more than happy to send you the dxdiag via inbox).

Problem: warhammer i graphics were great and ran very smooth... but now they dont, is like rome 2 -> Attila all over again. Even worse: with the last patch, performance is droping again.

Im talking about battles wich i had 60 fps steady in ultra in WI, then 45 (in high!!!!I) in warhammer 2 and after mortal empire i get 35 if im lucky. And it has mini freezing when some lord cast a spell that affects lots of soldiers around (VFX effects kills framerates).


Even in the map, in the wood elves area the fps drops all the way down to 20!

Why don you go back to the great warhammer I graphics, wich everyone could use at ultra settings with AAx2 instead of putting more things on top of it making it unplayable?

thanks!!!

Comments

  • StoreslemStoreslem Posts: 304Registered Users
    my specs are gtx1080, i7 7820hk, 16ram
    i just did battle benchmark for both games just to check diffrence.
    Game 1 :everything Ultra, shadows extreme, anti alising 8x, texture filtering 16x : 50fps
    Game 2 :everything ultra, shadows extreme, anti alising 8x, texture filtering 16x etc : 35fps

    i did a test on low settings just for fun also
    Game 1 : 278fps and it reached 370 highest!
    Game 2 : 220fps and 270 on highest point.
  • rad13rad13 Member Posts: 616Registered Users
    is that game 2 with or without the ME patch ?

    Game 2 ran like a dream for me originally, but with the ME update is significantly stutters and slows down on both the campaign map and in battles (although weirdly, it's more frequent on the campaign map)
  • MontresorMontresor Junior Member Posts: 320Registered Users
    I've had the exact opposite experience. Since ME, the game has run flawlessly for me. That may be because of an NVidia patch a few days before, though.
  • Prkl8rPrkl8r Junior Member Posts: 404Registered Users
    rad13 said:

    is that game 2 with or without the ME patch ?

    Game 2 ran like a dream for me originally, but with the ME update is significantly stutters and slows down on both the campaign map and in battles (although weirdly, it's more frequent on the campaign map)

    Could it be the blood pack?
  • Gunga_dinGunga_din Member Posts: 319Registered Users
    Had a considerable fps drop too, but only after mortal empires. Turning shadows to ultra from extreme makes it considerably better. If anything, I like the wh2 graphics way better. How they optimize it, because something went off on mortal empires patch
  • NeverBackDownNeverBackDown Senior Member Posts: 1,824Registered Users
    edited November 2017
    Runs fine for me..
    6700k OC'd to 4.2ghz
    1080 at 2000mhz.
    16GB 2800 memory
    2560x1440p
    Mix of Ultra and High but have shadows set to low and no AA. Shadows are a killer in TW titles, calculating shadows for every single model in real time is a performance killer.
    Performance is good for me with these settings.
  • FranzSaxonFranzSaxon Posts: 2,357Registered Users

    Runs fine for me..
    6700k OC'd to 4.2ghz
    1080 at 2000mhz.
    16GB 2800 memory
    2560x1440p
    Mix of Ultra and High but have shadows set to low and no AA. Shadows are a killer in TW titles, calculating shadows for every single model in real time is a performance killer.
    Performance is good for me with these settings.

    Yeah I have a great rig and i STILL keep shadows OFF. It hurts everything so much with them on. Especially cuz I mod blood not to disappear on the ground
  • CarbaCarba Posts: 7Registered Users
    Sad that CA doesnt show up :( i have been buying total war games since medieval, and i feel quite hurt now that im not getting any response from them
  • makar55makar55 Posts: 1,681Registered Users
    No-no-no, I would prefer play with 30 FPS than have graphics from Warhammer 1.
  • SeetheSeethe Posts: 182Registered Users
    Gotta love that 1 FPS from warp lighting cannon effect
Sign In or Register to comment.