Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Can't Dismantle Building in Primary Settlement

Cid333Cid333 Posts: 9Registered Users
This is so dumb. CA had to know the AI builds A LOT of useless buildings in primary settlements. Hopefully this is something that can be fixed by mods.

Comments

  • MattzoMattzo Member United KingdomPosts: 1,433Registered Users
    Huh? I can dismantle main settlement buildings just fine. Just hover over and hit the dismantle option. Only does 1 tier at a time though, which is a bit annoying.
    "Everything in war is simple. But the simplest thing is difficult."
  • Cid333Cid333 Posts: 9Registered Users
    You can go back to first tier but you cant destroy it completely.
  • MattzoMattzo Member United KingdomPosts: 1,433Registered Users
    I have done on several occasions.

    If you're referring the the first slot in the settlement, well, obviously not. That chain represents the city itself. It's fixed as a certain type.
    "Everything in war is simple. But the simplest thing is difficult."
  • Whiskeyjack_5691Whiskeyjack_5691 Posts: 2,463Registered Users
    The building in the first slot of Province capitals can't be destroyed completely, but everything else in the settlement can. It just doesn't destroy them outright, instead it brings it down 1 tier/level. So to completely remove a level 3 building, you'd have to "dismantle" it three times, until the building is gone.

    I agree it's an odd thing to change, but it's not an overly frustrating thing.
  • Cid333Cid333 Posts: 9Registered Users
    I guess I read the tooltip wrong. Thanks for clearing it up.
Sign In or Register to comment.