Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Low Performance with GTX 1080 Ti in 1080p?

dougiejonesdougiejones Registered Users Posts: 10
edited July 2018 in Performance & Graphics
Recently I've gotten a new PC with an i7 8700, 32gb RAM, 1080 Ti. With such specs I was expecting to slay this game, but to my surprise the FPS was pretty mediocre and drops often. It's mostly noticeable when I'm zoomed-in to battles, my FPS will fluctuate anywhere from the low 30s to low 50s, rather than a solid 60. My settings are all on ultra, aside from shadows which I have set to medium and AA which is on FXAA. The campaign map runs fine for me, and battles go pretty well until I get closer. As the title says, my resolution is 1080p which makes this even more strange. I'd expect that my GPU and CPU combo would shred the game at 1080p, but evidently not. Resolution doesn't seem to change much other than 1440p and 4K running only slightly worse. Game is running in DX11 and DX12 makes the problem worse.

I've noticed, oddly, that the FPS problem is *mostly* fixed when I disabled shadows completely, but in the Skaven benchmark it still lags pretty consistently (I get about 50 average in it). Speaking of the Skaven benchmark, it's by far the laggiest one for me, as the other two run perfectly on almost any settings, but this one seems to lag unless I turn everything to medium or low. Why is this happening?

I've been getting great FPS numbers in other games, so I don't really understand what's happening here. Even went back to play Warhammer 1 to see if it was better and it was by *a lot*. It only dropped to about 49 FPS on one occasion, and it was during a really rough battle that I had zoomed in very close to. I've tried uninstalling Warhammer 2 and reinstalling it, completely erasing all my GPU drivers and reinstalling them, adjusting Nvidia Control Panel settings, setting priority in task manager, etc. Nothing seems to work in improving FPS other than removing shadows, but surely this isn't normal... I should be able to run the game with all the max settings including shadows, yeah?

Any help is appreciated. Thanks.

I've included the preferences.script file.

Comments

  • UthoriusUthorius Registered Users Posts: 43
    edited August 2018
    To put it simply; Total War: Warhammer 2 doesn't scale well with multiple cores, and favors clock speeds over core count. Also, the game seemingly only utilizes a singular core to the full extent. Which, in your case, is quite problematic. Considering you have an i7 8700 and therefore those cores run at a much lower clock speed, than older quad core that benefit from fewer faster cores in this scenario.

    Your GPU, especially on 1080p, is being bottlenecked for this reason. That is why the difference in resolution are not really noticeable as you mentioned. Sadly, there is not a whole lot you can really do ATM to fix the issue if you wish to continue to play on ULTRA settings. All you can hope for is for CA to implement better multi-core functionality in their game engine for future titles. Other than that, you can always lower certain grapical settings such as; Unit size, Shadows and Fog to gain more FPS.

    There are various Youtube videos, Benchmarks, and game reviews that all come to the same conclusion: Warhammer 2 does not care for your core count. only their speed. (To a certain extent, ofcourse.)

    Hope this helped you out in some way.
    Post edited by Uthorius on
  • dougiejonesdougiejones Registered Users Posts: 10
    Uthorius said:

    To put it simply; Total War: Warhammer 2 doesn't scale well with multiple cores, and favors clock speeds over core count. Also, the game seemingly only utilizes a singular core to the full extent. Which, in your case, is quite problematic. Considering you have an i7 8700 and therefore those cores run at a much lower clock speed, than older quad core that benefit from fewer faster cores in this scenario.

    Your GPU, especially on 1080p, is being bottlenecked for this reason. That is why the difference in resolution are not really noticeable as you mentioned. Sadly, there is not a whole lot you can really do ATM to fix the issue if you wish to continue to play on ULTRA settings. All you can hope for is for CA to implement better multi-core functionality in their game engine for future titles. Other than that, you can always lower certain grapical settings such as; Unit size, Shadows and Fog to gain more FPS.

    There are various Youtube videos, Benchmarks, and game reviews that all come to the same conclusion: Warhammer 2 does not care for your core count. only their speed. (To a certain extent, ofcourse.)

    Hope this helped you out in some way.

    Well that is a shame. I supposed there's no way I can increase clock speed?
  • UthoriusUthorius Registered Users Posts: 43
    edited August 2018

    Well that is a shame. I supposed there's no way I can increase clock speed?

    The thing is that, usually you would be able to overclock your CPU to a various degree. The main issue in your case is that you have the I7 8700 CPU. Which, is very limited in terms of overclocking potential. The I7 8700K is the "Unlocked" version of your CPU, and is basicly the same but overclockable.

    However, even if you bought the i7 8700K, it would require a good cooling solution like an AIO liquid cooler, or a beefy air cooled heat sink in order for you to gain a noticeable improvement in performance whilst still managing the temperature of your CPU. But even then it would still not be very noticeable in Total War: Warhammer.

    Something you could try to gain some improvement is this:
    • Disable CPU C-States in the Bios. (look up a guide for this based on your Motherboard)
    • Set CPU priority to "High" for Total War: Warhammer 2. (This can be found under the "details" tab in the Windows Task Manager)
    • Run the game with Administrator Privileges. (go to your Total War: Warhammer 2 folder -> Right click on "Warhammer2.exe" -> select properties -> click on the compatibilty tab, and enable Run this program as an administrator)
    • Untick CPU core 0 in Processor Affinity. (This can be found under the "details" tab in the Windows Task Manager)
    • Set your CPU power plan to "High Performance". (Go to Settings -> type "Choose a power plan" in the box above -> select "High Performance" under preferred plans)
    Note that even with these changes, there might not be a noticeable improvement in the performance of Total War: Warhammer. But if executed correctly, are only going to be beneficial in terms of performance in general. It's going to vary based on the program.

    P.S

    When you untick CPU core 0 in Processor Affinity, and the result causes you to lose performance in Total War: Warhammer 2, just enable it again using the same method.




  • HuntingDogHuntingDog Senior Member Registered Users Posts: 1,470
    What Uthorius said.

    In addition, I would suggest taking another approach to TW-WH graphics/performance. Since, as u experienced, it's impossible to hold 60 fps in all situations it might make more sense to give up 60 fps and to settle on locked (with MSI-Afterburner) 30fps and to raise resolution (since u have unused GPU power) with DSR. Maybe even trying 4k.

    Higher resolution greatly benefits TW graphics because of the very high amount of small details.

  • dougiejonesdougiejones Registered Users Posts: 10

    What Uthorius said.

    In addition, I would suggest taking another approach to TW-WH graphics/performance. Since, as u experienced, it's impossible to hold 60 fps in all situations it might make more sense to give up 60 fps and to settle on locked (with MSI-Afterburner) 30fps and to raise resolution (since u have unused GPU power) with DSR. Maybe even trying 4k.

    Higher resolution greatly benefits TW graphics because of the very high amount of small details.

    For me, I can live with just playing at the current FPS. The drops aren't unplayable, and if I ever want to play on a mostly-consistent FPS of 60 I can just turn shadows off. A shame that's what I have to do, but it is what it is.
  • dougiejonesdougiejones Registered Users Posts: 10
    Well, I've discovered that turning off blood removes all my FPS problems in all resolutions. I hate that I have to but a fix is a fix, I guess.
  • MrwaylayMrwaylay Registered Users Posts: 128
    This is an issue users with higher-end systems have been reporting since the introduction of ME / Blood and Gore. I’m one of them. Essentially I’ve had to implement ALL of the above mentioned fixes, and disabled blood to get a fairly stable frame rate. However, if Skaven / Tk’s / Vamps are involved, all bets are off.

    What I found helpful was disabling the in-game Vsynch, and instead applying it via the Nvidia control panel.

    Like yourself, my rig is above and beyond CA’s recommended spec for solid 60 fps on Ultra. Sad thing is, in the early, vanilla days of the game, it actually ran really solidly. Then ME / Blood came along, and the problems started (just like they did in WH1).
  • BiesliekBiesliek Junior Member Registered Users Posts: 43
    Try the Less Blood Less gore! 2 mod, it worked wonders for my FPS. And I'm running Total Warhammer 2 on a 5 year old I5 with a 1060, with Max unit Lod.
  • dougiejonesdougiejones Registered Users Posts: 10
    Biesliek said:

    Try the Less Blood Less gore! 2 mod, it worked wonders for my FPS. And I'm running Total Warhammer 2 on a 5 year old I5 with a 1060, with Max unit Lod.

    Doesn't work. The issue isn't that my system can't handle it but rather the game or the game's engine isn't properly optimized for my CPU and others like it.
  • gorbongorbon Registered Users Posts: 1
    edited August 2018
    game is unoptimized, I have i7 8700k and it runs like crap, never goes above 40 fps
  • BiesliekBiesliek Junior Member Registered Users Posts: 43
    Yeah did a upgrade for my brother's pc.

    Newest Ryzen 7 2700x
    1070 TI
    16 gig ram
    installed on the extremely fast samsung evo 970

    Barely any increase in fps over my 5 year old system, maybe 10 15 seconds faster load times but with the exact same settings still gets fps drops. I read somewhere that powerful single core > more cores for the purposes of gaming, but I don't know how true that is.
  • dougiejonesdougiejones Registered Users Posts: 10
    Biesliek said:

    Yeah did a upgrade for my brother's pc.

    Newest Ryzen 7 2700x
    1070 TI
    16 gig ram
    installed on the extremely fast samsung evo 970

    Barely any increase in fps over my 5 year old system, maybe 10 15 seconds faster load times but with the exact same settings still gets fps drops. I read somewhere that powerful single core > more cores for the purposes of gaming, but I don't know how true that is.

    Not at all true. More cores, by and large, improve performance for the majority of games, but not so for some. Total War games seem to be part of that exception and, if I were to guess, due to the engine, is not so optimized for the most modern cards.
  • kmansp38kmansp38 Registered Users Posts: 185
    Observed the framerate on a 1070, and couldn't tell much of a difference between that and my 1060, both i7 7700 machines. Finally upgraded my 1060 to a Duke 1080 GTX and this made a considerable difference- it stays 50 to 60 on ultra @ 1440p, but does occasionally dip to 40's when zoomed in. Very rare. If I have it on 1080p, it rarely dips below 60 fps. Overall pleased, but I cannot believe the requirements to get this game to play well. It's ridiculous. This game engine is HORRIBLE- and I'm sure we will deal with the same issues with three kingdoms.

    The zoomed in on the battlefield issue seems to be there in almost every total war game with warscape- some worse than others. It's really bad when blood is enabled.
    i7 7700K 4.7 Ghz
    Nvidia Duke 1080 8GB
    16 GB Ram
    500GB SSD
    Windows 10

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file