Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Game Crashes at specific turn after pushing "End Turn" button

Saltyfork1Saltyfork1 Registered Users Posts: 1

Build: 1.3.0

Detailed description:
Hi I'm having an issue where the game is crashing right after I hit the end turn button. It stops right when it goes to the first NPC faction, the Order of the Loremasters. It doesnt quite make it to them (their logo is slightly right of center) and then Warhammer II stops responding. Turn 77. Lothern Campaign.

I've tried updating all my drivers (the warhammer launcher said they might be out of date and I hadnt done that until now). My drivers are good now and the issue is still happening.

I've also tried loading back to earlier saves (Turn 75) and replaying to that point and that did not work either. I've tried doing different actions in prior turns to change circumstances at turn 77 but it still happens at that turn and only that turn.

I also tried adding the mod "Community Modding Framework" and "Crynsos faction unlocker" and "immersive battle banners" in the hopes that adding mods might change something. Didn't work.

Comments

  • GamgeeGamgee Senior Member Registered Users Posts: 2,232
    I'm on turn 208 ish and having the same issue. Lothern is crashing my game on end turn. Playing Tomb Kings.

    GTX 1080ti
    i7-7700k
    32gig DDR4 ram
    windows 10
    All drivers up to date.
    Prophet of Cathay.
  • mharoun35mharoun35 Registered Users Posts: 3
    I'm also having same issue on Turn 128. My crash happens at end of the Turn right before its my turn to control things again.

    I tried going back and doing different things but i still crash at end of 128. Not sure what is causing it or how to avoid it.
    I tried re-installing the game and still i crash
    I tried erasing the data folder and verifing the files on steam forcing a re-download and still i crashed.


    GTX 1080
    i7-7700k
    32gig DDR4 ram
    windows 10
    All drivers up to date.
  • GamgeeGamgee Senior Member Registered Users Posts: 2,232
    I should also mention I am on a samsung 960 evo as well no idea if that would affect something like this but good to get out there.
    Prophet of Cathay.
  • LiQuiD1389LiQuiD1389 Registered Users Posts: 4
    *You crash when Ai turn,*
    *Welcome to the club,*
    *now you can give up*
    *cause Devs dont give a *****
  • NocereNocere Registered Users Posts: 4
    edited February 2018
    Thats pathetic CA insted hireing a beta testers or wharever sold us a buggy crap and want us to waste time to send them files and they dont do anything to solve this
  • elnaoelnao Registered Users Posts: 2
    Same for me: turn 218, i pass turn and game crashes when the Empire's turn begins. It crashes with no error message, so i uninstall the game, update all my drivers do anything possible: nothing works, the save is comdamned. So much hours for nothing?
    I can't even put the explicative video (1min) to this comment.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file