Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Lag during battles

MendicantMonkMendicantMonk Registered Users Posts: 3
edited January 2019 in Performance & Graphics
Build number: 8774.1520175

I randomly get some pretty bad lag during battles and I don't know what causes it exactly. I have seen it happen when my archers loose a volley of arrows, but not every time. Never seen it happen when artillery fires either. Panning the camera away from the battle sometimes helps, maybe it is large unit size?

I usually play with no browsers or other programs running in the background.

edit: forgot to say that it occurs regardless if I am using mods or not

Comments

  • CA_HamishCA_Hamish Registered Users, Moderators, CA Staff Mods, CA Staff, SEGA Posts: 131
    Hi @MendicantMonk

    Sorry to hear you are encountering this performance issue.

    I would recommend running a performance monitor during battles to see what resources the game is utilising and if any other programs are running the background that you are unaware of.

    If you are able to run a benchmark and a reply with a screenshot of the results, it will highlight any performance stutters in the game.

    Thanks,
    CA_Hamish
  • MendicantMonkMendicantMonk Registered Users Posts: 3
    edited January 2019
    Hello @CA_Hamish,

    here is a screenshot of the battle benchmark:


    and here is one of the skaven benchmark:


    edit:
    adding a screenshot of performance monitor during a small battle (17 units total):

    Post edited by MendicantMonk on
  • CA_HamishCA_Hamish Registered Users, Moderators, CA Staff Mods, CA Staff, SEGA Posts: 131
    Hi @MendicantMonk,

    Thank you for providing the screenshots. The performance you are encountering is within our expected range with the hardware and preferences that you are running with.

    In regards to the stutter I can see that your GPU (GTX 1050) is at 100% utilisation when in the battle, so that could be and indicator, however I would be surprised if you are GPU bound with your settings. If you are able to turn down the unit scale down and run an scenario where you would see the stutter to test whether it is the unit scale? Larger unit sizes are more straining on the CPU.

    Let me know how you get on.

    Thanks,
    CA_Hamish
  • MendicantMonkMendicantMonk Registered Users Posts: 3
    Hello @CA_Hamish,

    reducing unit size to medium smoothed things out considerably.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file