Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


"CD Key Invalid" Got you down?

Ace_BlazerAce_Blazer Senior MemberToronto, CanadaRegistered Users Posts: 5,918
edited August 2011 in Total War Eras Multiplayer
Originally posted by aurelius1.

I have good news and bad news. The bad news is right now, if you're reading this, you're frustrated and angry.

The good news is there is a simple fix.

When you enter your cd key (yes, I know, again :D ) make sure your caps lock is OFF. Use shift to put in the upper case letters, but remember NOT to make the numerals upper case. I know, upper case numerals don't exist, but there's some strange gremlin that makes the GameSpy lobby think that they do.

For those trying to install Medieval Total War, remember that if you are logging in with Viking Invasion installed, your old key will not work; there is a new CD key on your VI case you need to look at. The last tip is the one error you won't admit to making. An "O" is round when printed on the CD key, while a zero has straight sides. "0" Say it with me now:
"0" is a zero,
"O" is a letter.
  • Do type the hyphens
  • Don't type spaces

In the case of Rome Total War and Medieval 2 Total War, if you simply cannot get the right CD-Key working, read the post in the link below. If you live in North or South America and provide proof of purchase, an updated CD-Key [maybe for a Steam version] should be provided for you. It is unknown if this applies to people outside the Americas.


This should be a last resort, as SEGA is not guaranteed to give you a new key!!!
My Rome 2 PC: Intel i5-4670, nVidia 760GTX, 8GB RAM, 120GB SSD, NZXT Vulcan mATX case
Please view the Total War Forum: Terms and Conditions.
Buttons the Kitten needs your help. Click here to save a kitten today.
Post edited by Ace_Blazer on


  • DesmondDesmond Junior Member Registered Users Posts: 1
    edited July 2010
    does this mean we have to re-install the game? So when we first enter the cd-key upon installation it is not enough to enter the letters in small case? because it seems to work in so far as installing the game is concerned. I have been playing the game for a while now and have only just tried the multiplayer and this did come up yet I do remember typing in my cd-key with lower case letters, do I have to un-install and re-install just to type the key in again with upper case?
  • Seleucid KingSeleucid King Junior Member Registered Users Posts: 6
    edited December 2010
    i doubt that just change it in the cd key area

    i hope that helped i dont have this one all i have is rome and empire.
  • justyhawkjustyhawk Senior Member Registered Users Posts: 461
    edited August 2011
    I had this problem and found that if I uninstalled it and typed the cd key in exactly as printed with the "-" lines inbetween each number group it worked fine. That was for med 2 cd key I'm not sure if VI has the "-" printed along with the numbers.
  • locknessmansterlocknessmanster Junior Member Registered Users Posts: 8
    edited August 2011
    I have the steam version of Rome total war gold edition most of them work fine but alexander total war gives me the cd key error when trying to logon to multiplayer any idea how to fix that I have windows 7 home premium 64-bit
Sign In or Register to comment.