Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Northern Empire cities are all permanent ruins...

DwarfMasterRaceDwarfMasterRace Registered Users Posts: 1,986
edited May 2019 in General Discussion
In my current campaign most of the northern Empire cities are in a ruined state. They are owned by Empire factions and are fully built up in terms of buildings, and yet they remain a pile of rubble on the campaign map.

I also see a green haze over them... which suggests Skaven shenanigans. I know Mordheim is supposed to look like this, but why is Brass Keep and Kappelburg also in this state when they are normal occupied cities?

Only thing I can think is it's a bug or the Skaven have used Doomspheres and this is the result (haven't played as them yet since update). If so, I must say I really don't like seeing cities permanently destroyed on the map.

You should be able to rebuild them; I don't want to rule an empire of junkyards.

Edit: Ok never mind, I just saw another thread on this even though I checked before posting and swore I saw no other topics on it. Go ahead and close this one. :D

Comments

  • RikRiorikRikRiorik Registered Users Posts: 8,948
    If nothing else it’ll be nice to see the back of all these posts once the bug is fixed :smile: .

    But I imagine it is very annoying to experience it. Thanfully only played Helfs and Lizardmen since release and haven’t had the ”pleasure” of seeing it first hand.
    Lord of the Undermountain and your friendly neighbourhood giant (Dwarf)
    Favourite campaigns: Clan Angrund, Followers of Nagash and the new Huntsmarshall’s Expedition
  • DwarfMasterRaceDwarfMasterRace Registered Users Posts: 1,986
    RikRiorik said:

    If nothing else it’ll be nice to see the back of all these posts once the bug is fixed :smile: .

    But I imagine it is very annoying to experience it. Thanfully only played Helfs and Lizardmen since release and haven’t had the ”pleasure” of seeing it first hand.

    Yeah, sorry about that. :p

    It is pretty annoying, basically the entire north of the Empire as well as Sylvania and Kislev are green ruins. It makes them look like a giant deadland when this region should be a bustling centre of civilisation... :/
  • RikRiorikRikRiorik Registered Users Posts: 8,948

    RikRiorik said:

    If nothing else it’ll be nice to see the back of all these posts once the bug is fixed :smile: .

    But I imagine it is very annoying to experience it. Thanfully only played Helfs and Lizardmen since release and haven’t had the ”pleasure” of seeing it first hand.

    Yeah, sorry about that. :p

    It is pretty annoying, basically the entire north of the Empire as well as Sylvania and Kislev are green ruins. It makes them look like a giant deadland when this region should be a bustling centre of civilisation... :/
    No need to apologize friend xD!

    Especially annoying now that there are 4 (!) additional settlements to form av en ”bustlier” civilization.
    Lord of the Undermountain and your friendly neighbourhood giant (Dwarf)
    Favourite campaigns: Clan Angrund, Followers of Nagash and the new Huntsmarshall’s Expedition
  • Rolf1989Rolf1989 Registered Users Posts: 464

    RikRiorik said:

    If nothing else it’ll be nice to see the back of all these posts once the bug is fixed :smile: .

    But I imagine it is very annoying to experience it. Thanfully only played Helfs and Lizardmen since release and haven’t had the ”pleasure” of seeing it first hand.

    Yeah, sorry about that. :p

    It is pretty annoying, basically the entire north of the Empire as well as Sylvania and Kislev are green ruins. It makes them look like a giant deadland when this region should be a bustling centre of civilisation... :/
    Hey, would you mind taking a screenshot of it? I'm just curious what the bug looks like since I'm staying clear of Mortal Empires atm.
  • WothanazWothanaz Registered Users Posts: 82
    Rolf1989 said:

    Hey, would you mind taking a screenshot of it? I'm just curious what the bug looks like since I'm staying clear of Mortal Empires atm

    The bug looks make the empire settlements look like the Mordheim Ruins.






    Warhammer almost quoting Heraclitus:
    "Is not the only constant in the universe change? some day all this will be dust, and even the stars above us will flicker and grow dim. Your life is but a tiny candle in the darkness, and your death an afterthought shorn of meaning by its insignificance. Come, little one, and let me show you how your flame can burn bright..."
    -Vilitreska, Lord of the Flux
  • DwarfMasterRaceDwarfMasterRace Registered Users Posts: 1,986
    Wothanaz said:


    Rolf1989 said:

    Hey, would you mind taking a screenshot of it? I'm just curious what the bug looks like since I'm staying clear of Mortal Empires atm

    The bug looks make the empire settlements look like the Mordheim Ruins.






    Yeah, that's exactly it. Not sure if everyone is experiencing it the same but for me like a third of the Empire and all of Kislev is green ruins. I was worried this was an intentional effect of the new Doomsphere mechanic for Skaven, but if it is just a bug at least it should be a temporary eyesore. :D
  • neodeinosneodeinos Registered Users Posts: 6,309

    Wothanaz said:


    Rolf1989 said:

    Hey, would you mind taking a screenshot of it? I'm just curious what the bug looks like since I'm staying clear of Mortal Empires atm

    The bug looks make the empire settlements look like the Mordheim Ruins.






    Yeah, that's exactly it. Not sure if everyone is experiencing it the same but for me like a third of the Empire and all of Kislev is green ruins. I was worried this was an intentional effect of the new Doomsphere mechanic for Skaven, but if it is just a bug at least it should be a temporary eyesore. :D
    If you have ANY loading screens during your campaign then you will have that bug unless you captured Mordheim before you have the bug.
  • AlexronchettiAlexronchetti Registered Users Posts: 93
    Currently playing a WoC campaign. Yeah the settlement bug is quite disturbing.

    I fix the bug by razing every empire region 😂😂

    On a more serious note, yeah this must be especially annoying if you play as the Empire. Im staying clear of doing an empire campaign at least till this gets fixed.
    Kholek Suneater w/ Sword of Khaine, best fun i've had in years of TW!
Sign In or Register to comment.