Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Cannot get battles above 10-15 FPS

Ahoy there,

I am able to run the game just fine on to the campaign map, but once I go into a battle my FPS will not go above 10-15 and the battle is unplayable at that point. I feel like I am running a fairly good rig and have tried several different adjustments with no success.

I originally thought the issue was my CPU, so since it was an old i5 from the 17th century I went ahead and upgraded it to what I have now. Then I just moved my HD/Graphics to the new PC (using the Win10 tool for that process). I did a fresh installation of the graphics on the new computer and everything.

Running a benchmark test starts the video at 10-15 FPS and never goes higher. I have done a fresh install of the game/mods, tried adjusting the resolution and graphics settings; I also tried the main fix I saw online that seememed to work for most (adjusting the priority and the affinity in the Tsk/Mgr and taking off "Core 0"). I am assuming something is messed up somewhere, but I'm at a loss. So, I need to go ahead and call out the garrison reinforcements here. Need someone who is good at reading dxdiag,etc. because I am not sure where to go next.

I really need to at least subdue Gaul and usher in the dawn of Western European Civilization. Help a conqueror out


  • SirSmiteSirSmite Registered Users Posts: 2
    edited May 2019
    Yeah, I'm also having this exact same problem. FPS averages around 13-15.

    I recently came back to playing Rome II and never had my battles lag immensely. I used to sit at around a comfortable 70-80 FPS with my 1070. The campaign map seems fine and the initial setup phase on the battle map runs well too. It's only when I click to start the battle does it all grind to crawl.

    UPDATE: Ok, I know it sounds dumb, but seeing as there have been a lot of issues when it comes to mods and CA's latest patches, I'm not even surprised this method worked for me. I had around 40 or so mods active when playing Rome II and was getting 15 FPS. Turning them all off, I noticed that the lag was gone, battles were smooth as they should be. So, I thought that a mod was causing the issue. I turned them on one by one to single out the culprit, but noticed that a similar issue with the "mod limit" came up. Regardless of what mod I had active and in what order, once I reached a certain number, the game starts acting up. I then merged a lot of the smaller mods into one big .pack file until I was down to just around 15 mods, and then I started the game. Lo and behold battles are smooth again (well, still lags and stutters, but it's tolerable now), despite having the same mods that changed the same things before, just in a merged .pack file.
    Post edited by SirSmite on
Sign In or Register to comment.