Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


In ProgressTW WH2 won't launch.

galo21galo21 Registered Users Posts: 3
edited May 2019 in Crashes
Hii, the issue is that after the game launcher closes it stops.

Yesterday it worked just fine
I didn't add any mods nor hardware
I tried disabling all mods and pressing both "continue campaign" and just "play"

I wanted to ask you if there's anything else I can do before I uninstall and reinstall. I really don't want to loose my campaigns.

I use steam by the way.

Thanks in advance.
Post edited by CA_Nate on


  • galo21galo21 Registered Users Posts: 3
    (Total War: Warhammer 2)
  • SreeevesSreeeves Registered Users Posts: 3
    Same problem as me, it started this afternoon.

  • CA_NateCA_Nate Creative Assembly Registered Users, Moderators, CA Staff Mods, CA Staff Posts: 1,036
    Hi Everyone,

    Would you be able to do the following actions to see if it works:
    • Delete the launcher folder in appdata, located here: Drive:\Users\User\AppData\Roaming\The Creative Assembly
    If this solution does not work for you can you please provide us with the files below:
    • Launcher_log files, located here: Drive:\Program Files (x86)\Steam\steamapps\common\Total War WARHAMMER II\launcher
    • Modified.log files, located here: Drive:\Users\User\AppData\Roaming\The Creative Assembly\Warhammer2\logs
    Kind Regards,

    Forum Terms & Conditions

    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • spartan92spartan92 Registered Users Posts: 2

    I am having the same issue. I have tried reinstalling the game, deleting the app data launcher folder. I have had no luck with these solutions I have attached the required files. It is not just Warhammer 2 I am having trouble with it seems to be Rome 2 as well. any help would be welcome

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file