Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

multiplayer mod issues

wowVlornwowVlorn Posts: 1Registered Users
edited May 3 in Multiplayer Bugs
I know that I am going to be told just to disable the mods by all the people who are not helpful, but worth asking anyways.

I am trying to play a multi player game with someone else, we've done this many times, but we spend a lot of time trying to get the mods to work. Even when we do, the next time we play, it stops working. This only happened once the new mod manager was put into play. With the old manager, this was never a problem.

Whenever we try to join, it'll tell us we have different game version.

We both use steam for this and download the mods via steam. We are only trying 1 or 2 mods, nothing fancy. We've been able to get it working, but this time we are not. It's very frustrating.

I've searched long and hard and different solutions:

1- removing all the mods and adding them back again. Did this.
2- Manually removing all the mods by deleting them in their folder:
SteamLibrary\steamapps\workshop\content\594570\
3- Tried to remove the launcher files by removing
:\Users\\AppData\Roaming\The Creative Assembly\Launcher
4- We have tried to re-able to the old launcher under Beta --> launcher_release_candidate

There really needs to be the ability to sync mods with friends on Steam, prior to launching the game, even if they have to review them and approve them. Right now, it's beyond frustrating to not even want to play anymore.

Looking for any other suggestions.
Post edited by wowVlorn on

Comments

  • Harry_HoodHarry_Hood Posts: 9Registered Users
    I am having similar issues.

    1 - Switching Coop campaigns between computers (desktop to laptop or vis versa) no longer works when mods are involved.
    2 - Adding or deleting save-game compatible mods mid-game no longer works. It never used to be an issue in the past as long as both people were running the same mods.
    3 - After selecting mods from mod manager, lets say I pick 2, a dialogue box pops up saying are you sure you want to run these mods, etc. I am sometimes getting notifications that some disabled mods AND deleted mods are trying to load. The only fix was to reinstall the mod then delete it again.

    I've been playing a coop campaign with a few mods active, a game which started after The Prophet DLC. I noticed the problem when I tried to switch to my laptop one night. I've done this multiple times in the past with no issue. I copy the save game file to laptop and make sure same mods are active. However, this time as of recently it's not been working and I get the incompatibility issue.

    After hours of trial and error, it seems we cannot continue the game on any other computers than the ones we started on (my desktop and him on his desktop). Another issue is that I can't delete or add additional save-game compatible mods to the campaign because it doesn't even let me load the game. This was never an issue in the past. Even weirder, we tried to create a new game from our laptops, both running same version and just selected a 1-2 relatively minor mods JUST to test it out and we cannot joint each others game! The problem seems to occur when using mods only. I didn't have issues until this new launcher came out but not sure if that is the culprit.

    I suspect mods are not properly activating/deactivating causing the incompatibility issue but it is strange that we don't have issues with our desktops, just laptops and different combinations or desktop/laptop.

    I agree with the need for a new Sync system for Multiplayer.

    We have been putting in hours each night to figure this out and I will let you know if I get something to work. One suggestion that seemed to fix a couple of issues for me was to uninstall game, and delete entire steam workshop folder and TW folder (backup as necessary). I read some posts that uninstall was not necessary but I did it anyway. I also had varying results when we both used a mod manager instead of the CA launcher.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file