Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Medieval II: Definitive Edition - "encountered an unspecified error" when launching game

TheByfordTheByford Registered Users Posts: 3
I recently purchased the definitive edition of Total war Medieval 2 on Steam but I cannot play it. Every time I go to run the game a black screen appears with a dialogue box stating "Medieval 2: Total War encountered an unspecified error and will now exit"

I have been searching for around 2 days for a solution to this problem and, currently, not one thing I have tried has got me any closer to actually being able to play the game.

So far I have attempted;

-Verifying game cache in steam
-Uninstalling and reinstalling the game
-Uninstalling and reinstalling Steam
-Uninstalling and reinstalling Graphics drivers
-Changing "medieval2.exe" to "Launcher.exe"
-running "unpack_all" and then deleting the "descr_geography_new" files
-running the game as administrator and in various compatibility modes including "Windows XP (service pack 3)"
-Installing the game outside of "Program Files (x86)"
-Attempting to launch the game with various launchers including "bare_geomod"

I am aware this is a question that appears so frequently on these forums but nothing I have been able to find actually works. Quite a few people have posted almost identical situations to mine (where they have tried a lot of things) but no one seems to have been able to provide any clarity.

Any help would be greatly appreciated



Sign In or Register to comment.