Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


win10 x64 - Battles always CTD after 2-10 minutes w/o minidump under wide variety of conditions

CTD_throwawayCTD_throwaway Registered Users Posts: 2
Build: most current non-beta version (July 15th)

Detailed description:
As per title, I'm experiencing infuriating CTDs under a wide variety of conditions after I enter real time battles, at a seemingly random 2-10 minute interval (sometimes I'm able to complete a battle before I crash, but I've never gone longer than 10 minutes without a battle concluding OR more often a crash). I've done all the steps in the standard total war crash support guide, to no avail. I've crashed about 20 times at this point through 6 hours of game play, so it's very common.

Most recently I've crashed 4 times in a row while ambushing Huang Shao while playing as Liu Bei (quicksave). I've repeatedly gotten about 5 minutes into the battle before the crash occurs. I've played with and without 3 minor mods enabled, tried 3 different nvidia drivers, turned windows defender antivirus on and off (adding an exception for the entire folder), and with multiple preferences (windowed and non-windowed, unlimited vs not-unlimited memory, a huge slew of other various graphics options).

No minidump files or notifications are generated from the CTDs, which is frustrating.


  • miniman_obrienminiman_obrien Registered Users Posts: 18
    Weird idea - but it worked for me when I had TWTK problems - remove the 'run as admin' checkbox in the launcher found in the steamlibrary/common/totalwarthreekingdoms folder - its the directory where your steam games are located - does that help?
  • CTD_throwawayCTD_throwaway Registered Users Posts: 2
    It's not currently checked, and I'm still have the CTD problem. However, when I experimented with checking the main .exe to fix the problem I found that the launcher would consistently fail to launch the game - so I went back to having it unchecked. So clearly having that unchecked is good, but not the cause of this issue. Thanks though!
Sign In or Register to comment.