Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Crash on AI Faction Turn / Mortal Empires

2»

Comments

  • jtslugmaster08jtslugmaster08 Posts: 3Registered Users
    edited June 2018
    @cccr201 Interesting I think if you posted some files like i did up top it would help them. I tried playing my old save game that I posted about above and it worked! :) I started another play through without any issues currently(knocks on wood). I was about to post that they resolved the issue but maybe not.
  • jtslugmaster08jtslugmaster08 Posts: 3Registered Users
    edited June 2018
    @cccr201 Also my previous save game was a vortex campaign that was fixed. I dont know if you are playing vortex or mortal empires. Also My current play through is a mortal empires campaign Maybe they fixed it for one campaign but not the other?
  • cccr201cccr201 Posts: 7Registered Users

    .

    Yeah, sorry, I should have said that, I'm playing the Mortal Empires campaign

  • cccr201cccr201 Posts: 7Registered Users
    I wrote to the suuport of CA that suggest to delete the script files to make my laptot reset again the options but the crash is still happening
  • cccr201cccr201 Posts: 7Registered Users
  • Lazo93Lazo93 Posts: 2Registered Users
    This just happend to me right when wood Elves finish their turn it freezes and crashes, Im not using any mods Im playing Vanilla as the Empire on turn 225, Please help i was really excited about buying vampire Coast Dlc before this and it seems this bug has exsisted since 2017 at least.
  • GhoStBuSteR_GhoStBuSteR_ Posts: 1Registered Users
    Same here, playing as Tyrion and the game crashes on Wood Elves turn on turn ~250, no matter what I do. Vanilla game.
  • DeathnewgenDeathnewgen Posts: 1Registered Users
    I'm guessing this will never be fixed. Guess I have to do thorough research into anything these developers come out with. Not wasting money again. I've had random crashes at random points in 3 games. Just got the damn thing like a month ago. No I don't still have the saves. If this was an issue since 2017 and they refuse to fix it they most likely won't and regardless if they do I have to make sure their **** is 100% done before I even get to tooch it cause they obviously have a hard time producing something complete just like Bethesda and their most recent piece of work

    Actually, how annoyed I really am. I wasn't able to play Warhammer one to its fullest because of a **** computer.

    I spent 1400 on some new gear specifically to run this game and all the dlc........ For the incapability of completing a campaign due to the lack of attention from those suppose to maintain it.

    This needs fixed, has been needed fixed, and should be fixed. Some serious ****, at least I got a half decent system now. Perfect for never buying one of their **** games again, **** Warhammer 3 just to be ahead of the curb.
  • ZyrexiusZyrexius Posts: 1Registered Users
    Yup. Happening to me too. Playing as brettonia and during the empire taking its turn the game freezes. No previous saves worked, nothing. I'm done
  • leobeckfordleobeckford Posts: 1Registered Users
    Same problem ,
    Game crash on the final go of the ai.
    I think that this is connected to the latest windows update as I did a system restore to before the latest (critical) update and it continued to work.
    Problem is windows needs its updates and the game needs to be updated to run in sync
  • inarikettuinarikettu Posts: 1Registered Users
    Not even sure CA is taking care of this, however I have the same problem, on Hexoatl's turn 106, playing as Dreadfleet / Very hard, on Mortal Empires.

    I must agree on previous comments : this is really uncool not to fix this for people who have spent quite a bit of money on both games, all DLCs, and maybe even new hardware to run the game...
  • DumbledoodDumbledood Posts: 9Registered Users
    Turn 98, wood elves' turn (I'm playing as Empire), and it crashes. Running 45 mods so that might be the problem. Everything seemed to be running smoothly until now. Happy to provide more info if requested.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file