Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


CTD on End Turn

LucianWARLucianWAR Registered Users Posts: 2
Hi, this has made my main Dark Elves Mortal Empires campaign save unplayable. I had zero issues with it until I came back to the game after a little 2 month break. The game crashed when I ended turn, and it only got past Lothern and to 'Last Defenders' about 10 of my attempts, then I reinstalled to a new SSD and it now manages to get to 'Cult of Sotek' before crashing in the same way. I have tried disabling autosave, and disabling many of the mods, however the game crashes on save loading screen without some of the mods activated.

Build no: v1.7.2
12104.1770049 (modded)

All relevant files have been attached, and I hope we can resolve this! I love this game and this issue is really demotivating!

Cheers :)


  • LucianWARLucianWAR Registered Users Posts: 2
    This forum isn't exactly bustling with life. :p I really want to play this game, but the prospect of a save becoming unplayable once you've sunk so much time and effort into it is killing my willingness to even start a new campaign. I have tried most avenues on my own to fix this without any luck, and I hope someone can help shed some light on this issue soon!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file