Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

Campaign Crash End Of Turn

Deadzero2005Deadzero2005 Posts: 3Registered Users
Hello,

So I began a new campaign with the lizardmen using mortal empires campaign. I would finish my turn and about half way into the AI turn my computer would reboot. I have no mods, updated windows 10, update graphic drivers, etc.

I tried everything from uninstalling to window compatibility permissions installing the new beast beta and nothing is working. I started a new campaign as the dwarves and its doing the same thing. I just want to know if anything is being done about or iam just walking away from Total War

Comments

  • Deadzero2005Deadzero2005 Posts: 3Registered Users
    edited November 12
    No response from CA

    You named it I tried it. Verified files through steam, compatibility windows 7, set as administrator, directx11, no mods just the free dlcs, updated drivers, updated windows, clear cache files, system firewalls, bios updated, stress test gpu, ram and cpu using prime95 blend and heaven with good results, uninstalled blood god dlc, downloaded open launcher beta, beast beta, rolled back my gpu to older versions, etc. I looked everywhere on the web for solutions, tried them all even tuning down my gpu voltage to 80% using msi afterburn.

    This DOES NOT happen to any other of my games Stellaris, Total War Warhammer 1, league of legends, Baldurs Gate, Pillar of Eternity, etc. It has to be the game not hardware or software issues

    The last thing i can think of is the fact that i didnt buy vampires coast and beast hunter dlcs. Does that mean i need to buy those so this game can work? Looks like iam not finding answers here ill head over to sega.
  • xeksirtxeksirt Posts: 7Registered Users
    I have nearly the same problem, along with many others. CA doesn't care, the majority of people are happy with it. There were problems like this with their other games that were NEVER solved either. Look at the Charlemagne dlc, constant crashes from many people, never solved.
  • Deadzero2005Deadzero2005 Posts: 3Registered Users
    So I just want to give everyone an update on my situation. With no contact what so ever from CA and have been working with Sega support and they have been telling me the same possible solutions like verifying WH2 files through steam, check windows updates, etc. Nothing was working. So i dug deeper and i believe it was this site that some posted a similar issue and mentioned something about a faulty psu. So I said why not, i tried everything else. So i went ahead and purchased an Evga SuperNova 650w Gold PSU. My old psu that I installed back in 2016, is a Seagate M12II Evo Bronze 520w.

    So I just received my new psu today and tossed it in and started it up. I started a new campaign on mortal empires and I am pleased to announce that I am 3 turns into the campaign without a crash. I guess the psu did not keep up with the turn ending sequence power demand but it seems like it worked. Like I said, with no help from CA and the rinse repeat method from Sega, I found a post from another user stating a faulty psu was causing crashes and I just gave it a shot and it worked for me. Hope all of you find the cause of your issues and enjoy the game, thanks.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file