Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

[Guide] Enable Mods On Linux

McCoy!McCoy! Junior MemberRegistered Users Posts: 2
edited January 2016 in Mac & Linux Support
Manually download all mods or scroll to third post for a guide on how to find the .pack file for your Attila workshop subscriptions
Rename all .pack files to lowercase as linux is case sensitive (ex: Radious_Mod.pack to radious_mod.pack)
Place .pack files in Attila data folder (/home/username/.local/share/Steam/steamapps/common/Total War Attila/data)
Right click on .pack files and make sure ownership matches vanilla files
Also make sure "is executable" box is checked (also found done by right clicking in properties)
open /home/username/.Creative Assembly/Scripts/preferences.script.txt file
Here you include your mod at the bottom of the file
mod sharp_mod_v2.4.pack;
^^ Type "mod" then your modpack and add the semicolon at the end ;

Almost done! This file (preferences.script.txt) overwrites when you exit the game. This means you need to add your mods to this file every time you want to play Attila OR you can prevent this file from overwriting using a few different methods

Please note by preventing this file from overwriting your settings will no longer be saved! You manually tweak your settings by using this file (Your linux users after all so this shouldn't be too hard) or you will have to reverse the following instructions and reload the game.

First Method is right clicking preferences.script.txt file and setting it to read only (very simple)
Second Method is to open preferences.script.txt file and find this line at the top of the file
write_preferences_at_exit true; # write_preferences_at_exit , Write preferences at exit #
Now make the following change
write_preferences_at_exit false; # write_preferences_at_exit , Write preferences at exit #
^^This is pretty self explanatory

Done now your mod(s) will load everytime you start the game
You just need to ensure all the mods you have enabled are compatible

As a side note if you want to place all the mods you have in this file so you don't forget what you have this is possible
For example sharps mod and radious mod are incompatible but you want to play radious and not sharp this is how you would write it
mod radious_mod.pack
# mod sharp_mod.pack #
^^Just use hashtags to ensure the line is not read
I know some of this will be very obvious for some but I want to include everything in this guide to avoid any questions

Enjoy playing your favorite mods!
McCoy!
Post edited by McCoy! on

Comments

  • Matthias CAMatthias CA Administrator UKRegistered Users Posts: 2,596
    Thanks McCoy! :)

    I'm stickying this as it seems very useful.
    PLEASE READ THIS THREAD BEFORE POSTING YOUR ISSUE ON THE SUPPORT FORUMS.

    Need to contact us?

    Forum Terms & Conditions

    Formal disclaimer: any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • McCoy!McCoy! Junior Member Registered Users Posts: 2
    If you subscribe to a workshop mod you can find the .pack file in the following location
    /home/username/.local/share/Steam/userdata

    It may be a bit hidden so heres an example of what to look for:
    /home/username/.steam/steam/userdata/83652630/ugc/referenced/391050074847911743/mods/mod_diplomacy_char_to_vanilla.pack

    Hopefully I saved you an hour or two of searching lol
    Oh and if you don't find your subscribed mod in this area please note that sometimes the mod won't download until you start the game. So start the game, exit then try looking again

    Enjoy

    PS: Thanks for the sticky Matthias :)
  • BAntDitBAntDit Registered Users Posts: 1
    Does not work for me.

    Every time i put any .pack file into Atilla/data folder, the game stops launching.

    I've tested on linux mint 18.2.
  • anve8004anve8004 Registered Users Posts: 3
    Mods not working until I check "opt for beta program" in Steam and force update to Beta PATCH_6, then all the mods are working as described above..
Sign In or Register to comment.