Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Warhammer 1 not launching from either the Total War launcher or the .exe file

JudgementKazzy88JudgementKazzy88 Registered Users Posts: 2
edited February 2020 in Crashes

I bought Total War: Warhammer from Steam last night, and after the installation finished, I tried to run it, but the game did not start. While the launcher starts, and it detects my other installed Total War games, pressing play on Warhammer simply did not work. I had installed all the Free-LC alongside the base game as well. I tried to troubleshoot by myself (Uninstall, and Reinstall, Run on administrator mode, Empty the launcher folder, try to delete the scripts folder that does not exist because the game has never properly launched, and etc.) Other games like Rome 2 and Shogun 2 run perfectly fine, but Warhammer simply doesn't start (It doesn't even show up in task manager). I hope this can be fixed, as I am a big fan of the Total War series. I've attached my DxDiag.txt, if that is any help.


Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file