Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


After confederation, confederated lords and heroes lose all of their mount options.

gavin786gavin786 Registered Users Posts: 10
edited April 2021 in Campaign & Battle Bugs
Build: 18012.2223342 v1.11.0

Detailed description:

After confederation, confederated lords and heroes lose all of their mount options excepting what they were on at the time of confederation. It is either what they were on or 'None'. Appropriate skills are unlocked for the other mounts.

I am confederating Naggarond, playing as The Thousand Maws. Turn 169.

Reproduction Steps:
1. Confederate with Naggarond. They will confederate for ~213k gold
2. Select Malekith. He is standing next to Marienburg on the Campaign Map.
3. Select his details pressing the magnify glass button.
4. Try and change his mount, only 'None' and 'Cold One Chariot' is available.

The same is true for a confederated fire wizard who aught have access to Dark Pegasus but does not, only the Cold One she is on or 'None', so bug is not specific to Malekith.


Details of any solutions that have already been attempted:

I have tried reloading the game. I have tried exiting and reloading. I have went over the end turn, no change.
I have tried to use the 3rd party save editor software to change the mounts, but it just corrupted the file and I am not able to use this work around.

Please attach .replay for Battles or .save for Campaign.


  • MorelionMorelion Registered Users Posts: 2
    an old bug that has been hanging around for a long time .....
  • gavin786gavin786 Registered Users Posts: 10
    edited April 2021
    So I did manage to fix it eventually using the save game editor tool.

    For those who have same problem, open your save in save editor, load your faction characters, then find the characters whose mount you want to change, then just change mount on bottom right, save under a new name. If it is corrupted, choose a different save and try again.

    I suspect, though have not confirmed, if you use this method you will not be able to gain any achievements; I will confirm this or not once I complete the campaign.

    I still dont have access to the other mounts, but all I want is the pegasus for the wizard and dragon or on foot for Malekith. So I feel like I can play on in the campaign now. This began to look like second campaign I didnt want to finish because of bugs. Looks like CA don't want to fix any late campaign bugs that affect only turn 100+. Still waiting on the fix for Sword of Khaine bug that stopped me playing on in Chaos campaign.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file