Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

macOS Big Sur Rome II not launching properly from steam

WaterPanda37WaterPanda37 Registered Users Posts: 1
Hi, I just recently updated my Mac to the Big Sur operating system. Since the update, whenever I try to launch Rome II: Emperor Edition, a small box with the words "Rome II: Emperor Edition" appear and then disappear after a couple of seconds. The game is definitely running, as I can hear the background music and skip the beginning intros. However, I cannot see the game screen at all or interact with the interface with my mouse and/or keyboard. Any ideas?

Comments

  • georgechompergeorgechomper Registered Users Posts: 2
    Did you fix this?
  • MPMFV50MPMFV50 Registered Users Posts: 1
    I

    Hi, I just recently updated my Mac to the Big Sur operating system. Since the update, whenever I try to launch Rome II: Emperor Edition, a small box with the words "Rome II: Emperor Edition" appear and then disappear after a couple of seconds. The game is definitely running, as I can hear the background music and skip the beginning intros. However, I cannot see the game screen at all or interact with the interface with my mouse and/or keyboard. Any ideas?

    I'd love to know if you've found a fix!!!!!

  • DCSchaefDCSchaef Registered Users Posts: 2
    I am having the exact same issue. I can hear the game playing but there is no visual evidence of the game being launched other than the dock having disappeared and the menu bar reading "Rome2". Any help would be appreciated.
  • DCSchaefDCSchaef Registered Users Posts: 2
    Turns out it's a 32-bit/64-bit thing. Which stinks.
  • Flofo92Flofo92 Registered Users Posts: 2
    I'am having the same problem. I just updated to the Big Sur Version 11.3.1 and it still doesn't work.
    I bought the game today on steam :-(
Sign In or Register to comment.