Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Categories

In ProgressGriffin Patriarch - can't recruit after defeating

PrimeDirectorPrimeDirector MemberRegistered Users Posts: 44
edited September 14 in Campaign and Battle Bugs
I accidently posted this in general discussion, but thought I'd put it here instead. I just defeated the griffin patriarch as Achilles, and I can't seem to find anyway to recruit him, even on the next turn. When I click on the symbol in the top bar, I get bugged out images and nothing happens when clicking the buttons. Also, Patroclus, who went on the expedition to defeat the griffin, is stuck in some mountain way up north. I had to just demobilize his army. Here are some screenshots. Using Epic by the way, no mods.




Post edited by CA_Dimitar on
Tagged:

Comments

  • CA_DimitarCA_Dimitar Registered Users, Moderators, CA Staff Posts: 157
    Hello @PrimeDirector ,

    Thanks for your report and detailed screenshots. Could you please provide us with save files before and after the quest battle(If possible). Additionally, are you using any mods or 3rd party software we should be aware of?

    Cheers,
    Dimitar
    CA Sofia QA Team

    FORMAL DISCLAIMER: Any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • Syr95Syr95 Registered Users Posts: 1
    I have the same problem (with Achilles and griffin) but i don't have a backup before the battle and i didn't use any mods or software.
  • SkollopsSkollops Senior Member Behind you :ORegistered Users Posts: 3,307
    Same problem here, though with penthesileas and the Cerberos



    Savegame before and after battles attached (at least I think the save is the round before)
    Previously known as DenmarkRules
  • CA_DimitarCA_Dimitar Registered Users, Moderators, CA Staff Posts: 157
    Hello @Skollops ,

    Thanks for your report and the provided save files. We were able to reproduce the issue internally and it has been sent to the dev team for further investigation.

    Cheers,
    Dimitar
    CA Sofia QA Team

    FORMAL DISCLAIMER: Any views or opinions expressed here are those of the poster and do not necessarily represent the views or opinions of The Creative Assembly or SEGA.
  • epic_159732899043dqsZmtaepic_159732899043dqsZmta Registered Users Posts: 1
    Same issue in my Ajax campaign with Cerberus. Playing with no mods on Epic



    pic
Sign In or Register to comment.