Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


In ProgressEnd Turn Crash



  • #732386#732386 Registered Users Posts: 2
    Happened to me in my first campaign, then I read this post and tried to play a new campaign of Demons of Chaos without using allied armies but it didn't work, it crashed in turn 150. My first campaign around 130 when that allied army was about to get smash. I feel discourage to play the gane in this state to be honest.
  • ReevaReeva Registered Users Posts: 6
    edited April 5
    This crash still exists after patch 1.1.0

    I mean... shouldn't you guys disable "request army" feature until this is fixed? It's more likely that others will encounter the same issue.
  • steam_16451940021126WQUBPsteam_16451940021126WQUBP Registered Users Posts: 8
    I don't think it's the request army feature, I'm wasn't using it in either of my campaigns and they're both bricked, one at turn 115, and another at turn 121 :(
  • YoYo Registered Users Posts: 6

    I don't think it's the request army feature, I'm wasn't using it in either of my campaigns and they're both bricked, one at turn 115, and another at turn 121 :(

    Perhaps the crash is also triggered when NPC factions lose armies that have been previously requested by another NPC faction. Totally speculation, but if the AI uses this feature, much of the implementation code would be shared.
  • ReevaReeva Registered Users Posts: 6

    I don't think it's the request army feature, I'm wasn't using it in either of my campaigns and they're both bricked, one at turn 115, and another at turn 121 :(

    well in this case I think you should file a report, upload savefile and other stuffs cause your case seems different and they might look into it.
  • Splitz#2375Splitz#2375 Registered Users Posts: 7
    Splitz said:

    Same issue around the 100 turn time, multiple times. Demon Prince, hired army (and fired) and kept happening because the army is wandering in enemy territory and gets whacked. After I set back my starts multiple times from 90's into early 100's and this ends up being nearly unavoidable. Stopped playing, and this needs a fix.

    Issue still remains, and thus still unplayable.

  • steam_164511865351Pt5cSvZsteam_164511865351Pt5cSvZ Registered Users Posts: 1
    Same issue here. Hired army dies, crashes at end of turn. Legion of Chaos.
  • sanchinsanchin Registered Users Posts: 1
    Same happens to me on 1.1.0 as Demon Prince. I've just killed the army I used to borrow from my then-ally = crash at the end of turn. If I spare them, it works.
  • YoYo Registered Users Posts: 6
    Can't believe this bug is still in the game...
  • Latex001Latex001 Registered Users Posts: 2
    Turn 128 - ex hired army dies, chaos undivided
    Same crash....
  • SinuheSinuhe Registered Users Posts: 1
    edited April 17
    Same crash. Legion of Chaos, turn 182, going for domination victory, ex-hired army dies - game dies at the end of turn. Im waiting for the next patch.

    A few turns earlier, I solved the problem by loading the previous save and saving the army, because then it was still mine. This is impossible in the current turn. Such bugs keep me from playing on the legendary difficulty level, where you only have one save file.

    Build 1.1.0 (no mods)
    PC: Windows 10 pro (all updates), AMD5900X, 32 [email protected] gskill, nVidia 3090 Zotac Trinity, 2TB Samsung 970 EVO plus
    Post edited by Sinuhe on
  • Dezka-knikDezka-knik Registered Users Posts: 1
    Also got this issue, already at patch 1.1.
    Legion of chaos, allied army hired by me, get destroyed during ai end turn time, and at the moment of last ai turn game is freezing and crashing.
    The question is it recoverable?
    Because i played legendary with autosave option only, which seems to be ruining the playthrough, because autosave occurred right after the battle of this army being destroyed
  • steam_164456858683HqaTNtvsteam_164456858683HqaTNtv Registered Users Posts: 3
    Having the same crash, but have not borrowed any armies during my campaign

    Playing as Daemons of Chaos, end of turn 97/crashes at what would be start of turn 98

  • lizano78lizano78 Registered Users Posts: 2
    Same issue here on a 4 person multiplayer campaign that we are unable to continue. Any updates on the issue yet ? Can you fix it from sending the save file ?
  • YoYo Registered Users Posts: 6
    How many more months until I can play the game and not be afraid of running into this gamebreaker?
  • Ikillyew3Ikillyew3 Registered Users Posts: 4
    Was there a fix or am I just stuck in this infinite loop
  • 13am5ir13am5ir Registered Users Posts: 10
    Game version 1.2.0
    I play as Slaanesh. During the mission, I call on a mercenary army. As soon as she dies, at the end of the turn, the game crashes, and the computer goes to reboot.
    When playing for other factions, the same thing happens. Somewhere a mercenary army dies, and at the end of the turn the game crashes.

    After 2 patches the problem is still there. This makes it impossible to play the game.

    This problem is reproduced by many people, and it is quite critical. I would call it a blocker. It is difficult to understand why she was not given a high priority and not fixed in the first patches.
  • erponxaos#9058erponxaos#9058 Registered Users Posts: 18
    Had the same bug for Khorne, Nurgle and DoC campaigns and i was lucky that an older save worked.
    I was not so lucky with my Tzeentch campaign which crashes on turn 133 so the last time i played TW3 was 2 weeks before patch 1.1.0. I played only 1 hour in patch 1.1.0 and 1.2.0 in which i tried different combinations with the same result.
    I even gave feedback with required files and no developer responded. Patches 1.1.0 and 1.2.0 had several pages of stats and values fixes which is the easy part just to make their patches seem big and a combined number of 4 lines for code/optimization/bug fixes.
    Tbh my hopes for this game are really low with no expectations of a solid IE experience since like @13am5ir said major bugs have not been fixed and they are nowhere to be found on the really slow ''roadmap''.
  • lizano78lizano78 Registered Users Posts: 2
    Could you guys at least let us know that you are working on the issue... And reach to GeForce Now to allow them hosting your games, what does it cost you...
  • Splitz#2375Splitz#2375 Registered Users Posts: 7
    Bump. Feel that chaos rage? No patch for a game ruining bug that should be easy to fix since we are all reporting the same thing.
  • CybertryxCybertryx Registered Users Posts: 9
    Got the same issue for me its at 57 and there isnt even rly much that i could have done to get that because thats legit turn 1
  • steam_164537217508jaO61uHsteam_164537217508jaO61uH Registered Users Posts: 6
    And here we go guys, patch 2.1 AND THIS BUG IS STILL ALIVE AND WELL! @CA_Dimitar

    Hey all

    Thanks for all the reports and the provided giles. Your issue has already been sent to the dev team


    When my dear sir? WHEN WILL IT BE FIXED!

    I started new campaign with Archeon, borrowed army from Norsca vasal, few dozens of rounds later, army dies, my game dies with it, crashed.

    When CA?! I paid 100 Euros (rounded) for this game and it's main future makes this game unplayable since day one!
  • KoohalkuKoohalku Registered Users Posts: 1
    edited September 7

    i got on turn 83 of a Sylvania run and i just cant finish the turn 83 when i try to end turn a crash at the 84 nations.I suppose that they are killing an other nation and it just make the game crash.
    Do i need to wait for an update ?
    I dont want to try to return to much in the past of the run to find that it doesnt change the fact that it will be block.

  • Monsterod#2282Monsterod#2282 Registered Users Posts: 2
    edited November 20
    This is still a thing. One that now had happened to me in 100% of games when borrowing an army that then dies. Most recent case is the best yet as it turns out when you borrow an army from a faction that uses Loyalty then it almost always gets to you with 0 loyalty.

    So I get a full army with 0 loyalty and no move and you can not give it items to try and fix the loyalty. So instant defect and then I have to kill it or it just suicides on my city. It then crashes a couple army moves after that.

    Lucky for me I don't have to go back to far to just not borrow the army.

    Really should turn off loyalty functions for borrowed armies or just turn off army borrowing until this is fixed.
  • Splitz#2375Splitz#2375 Registered Users Posts: 7
    Good to know this is still a game ending bug. Bad to know that they haven't fixed a relatively easy thing (or they are bad at coding). Frankly, this is ridiculous given this franchise success. Will be witholding $ in future buys.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file