Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Unable to start battles in TWW3 post Update 2.0

caladohel#8484caladohel#8484 Registered Users Posts: 6
edited August 30 in Crashes
Hello, I hope someone can help me,

Since the update came out and released the dlc along with it I havent been able to load any battles, the campaing map loads and runs well, however when I try and fight battles manually, the game starts to load the battle and then after a while it Crashes to Desktop,

I have tried updating the graphics drivers,
Verifying file integrety,
uninstalling and reinstalling the game,
restarting campains both in Immortal empires and Real of chaos,
disabling all overlays (NVIDIA and Razer),
updating Windows Drivers,
disabling Anti Virus and Firewall,
and running the game as admin.

I sincerelly hope someone can help me with this


  • action_johnny#9472action_johnny#9472 Registered Users Posts: 12
    Having a similar issue. It doesn't crash all the time, but the amount of times the game crashes either side of a battle loading screen (before or after battle) is massive.
  • Aquaboogy6563Aquaboogy6563 Registered Users Posts: 3
    I have not been able to play a battle since update 2.0. Same problem. Crashes directly to desktop after loading a battle.
  • caladohel#8484caladohel#8484 Registered Users Posts: 6
    The update came and nothing changed, Still not able to start any battle wheather that bevs AI skirmish or during campaing, everything else works fine, doesn't create any crash logs, it simply crashes to desktop, and once again i say, that this only started happening after 2.0.

    C.A, im asking for your assistance as currently i cant play a major part of the game.
  • NegradamusNegradamus Registered Users Posts: 2
    Manual battles have been nearly impossible for me to play without a CTD. Have tried a long list of fixes from clean install (including app data folders) to editing registry and the weirder ones like disabling steam overlay to limited success
  • caladohel#8484caladohel#8484 Registered Users Posts: 6
    Another Hotfix, still no changes, it still CTD's while loading manual battles, regardless if they are skirmish or campaing or quest battles, I bought the Champions of chaos dlc when it came out and have been a suporter of the series since warhammer 1, I have never had this problem before 2.0.

    Once more I'm asking you C.A to at the very least comunicate that you are aware of the problem
  • Charles496Charles496 Registered Users Posts: 4
    Same problem as everybody: everything work very well except manual battle… WTW3 crash at the end of the loading phase.
    Thank you for helping and I hope that you will fix it ASAP!
  • Charles496Charles496 Registered Users Posts: 4
    I found a solution on this forum and it works:

    1. Open regedit, go to HKEY_LOCAL_MACHINE/SYSTEM/ControlSet001/Control/GraphicsDrivers
    2. Create a new REG_DWORD: TdrLevel, set it to 0
    3. reboot to let new key take effect

    I did exactly this stuff whereas I am really bad in computer feeling
  • caladohel#8484caladohel#8484 Registered Users Posts: 6
    The solution you proposed Charles496 din't work, if anything it crashes faster than before, barelly going throu the loading process, I thank you for your atempt to help
  • Earlybird#2907Earlybird#2907 Registered Users Posts: 1,147
    Same here
    CA hasn't aknowledged this problem so i dont think it will be solved soon

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file