Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.


Gor Rok Mace bug Immortal empires

CiaránFrench#9124CiaránFrench#9124 Registered Users Posts: 3
Hey there, there is a bug with Gor Rok I believe, doesn't matter how many Skaven settlements I sack, the counter for his Mace quest doesn't complete or even show any progress beyond zero.


  • Stahn#1355Stahn#1355 Registered Users Posts: 3
    Having the same issue. You can sack or raze and it doesn't count basically leaving this LL without his weapon. Needs a fix. Sad, he was the first mortal empires I tried when I first bought TW2 and I was hoping to try him again in TW3, but with his quests being broken right off the bat I think I'll wait on him.
  • CiaránFrench#9124CiaránFrench#9124 Registered Users Posts: 3
    Yeah its quite annoying, found posts on the subreddit going back to nearly 3 weeks on this topic, still no fix.
  • phermitgb#4197phermitgb#4197 Registered Users Posts: 1
    ditto here - also having another questing issue with tyrion's heart of avalorn, and apparently there's a prevailing bug with Kislev not updating quest objectives. Seems like whatever system they're using for tracking quest objectives is failing, possibly on multiple levels.
  • CiaránFrench#9124CiaránFrench#9124 Registered Users Posts: 3
    As of the latest patch its working, you can now get Gor Rok's mace :smile: , now I can finally play him.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file