Avatar

Welcome

Please register for Total War Access to use the forums. If you're an existing user, your forum details will be merged with Total War Access if you register with the same email or username. For more information please read our FAQ’s here.

Badges

Its Over 9000!!So Popular! Much Wow!100 Likes - Eat Cake!So Popular!Somebody Likes You!Name DropperFourth AnniversaryThird AnniversarySecond AnniversaryFirst AnniversaryFifth Anniversary10000 CommentsCombo BreakerFirst Comment10 Comments100 Comments500 Comments1000 Comments2500 Comments5000 CommentsPhotogenic

BillyRuffian · Moderator

About

Username
BillyRuffian
Location
UK
Joined
Visits
1,284
Last Active
Roles
Registered Users, Moderators, Knights
Points
919
Occupation
Compliance
Location
UK
Badges
21
Posts
31,011

Activity

  • HGB87
    Hi billy. Been trying to get your attention. didn't know I can message you like this. I see you helping others, please help me. My game wont even launch after I click play. I never downloaded any modes For total war Warhammer only for rome 2 I did. After this foundation update and norsca dlc release I have been having this issue. after I click play in ttw launcher on steam it says its running for like 3 seconds then it just never ever starts. from what my system tells me and with the help of a driver update tool that I paid for, it says everything is up to date, (amd drivers, windows update etc) pleas help me. how do I post my DXdiag or anything else you may need? I'm just getting into learning more about desktops so not familiar. PLEASE help!
    August 11
  • BillyRuffian earned the Its Over 9000!! badge.
    You received 500 Likes. It ain't no fluke, you post great stuff and we're lucky to have you here.
    June 26